开放式最短路径优先(福彩三d字谜)是一种标准路由协议,’已经被世界使用了很多年。几乎所有路由供应商以及开源社区都支持福彩三d字谜,福彩三d字谜是IT行业中为数不多的协议之一,您可以依靠它在几乎任何需要的地方都可以使用它。

超出单个站点的企业网络通常会使用福彩三d字谜来互连其园区和广域网(WAN)。

如果您由于网络的静态路由已超出范围而考虑使用动态路由协议,则福彩三d字谜似乎有些令人生畏。这不是那么容易 设置为EIGRP 因此,诱惑可能只是简单地使用EIGRP,而避免使用对福彩三d字谜的完整理解附带的令人生畏的术语。

我的建议是不要让福彩三d字谜吓you您。确实,大型实现中的福彩三d字谜可能很复杂。但是,支持较小网络的福彩三d字谜配置可能相对简单。

在这篇文章中,我’将讨论福彩三d字谜的一些主要原理,然后进行简单的配置,该配置将在两个Cisco路由器和交换路由之间建立福彩三d字谜。

福彩三d字谜的大创意

福彩三d字谜是路由协议。互相使用福彩三d字谜的两个路由器交换有关他们知道的路由以及到达那里的成本的信息。

当许多福彩三d字谜路由器属于同一网络时,该网络中的所有福彩三d字谜路由器(在技术上称为“ 。 (我们将继续讨论面积)。

每个福彩三d字谜路由器都会将有关其已听说的路由和成本的信息传递给所有相邻的福彩三d字谜路由器,称为 邻居.

福彩三d字谜路由器依赖 成本 计算它们自己与远程路由器或网络目标之间通过网络的最短路径。最短路径计算使用 Djikstra的算法。该算法不是福彩三d字谜独有的。相反,它是一种数学算法,恰好在网络中有明显的应用。

考虑一个连接五个路由器的简单示例,如下图所示。假设所有链接的成本相同,那么R3连接到R5的最快方法是什么?通过R4—R4是成本最低的路径。 (例如,R3通过R1到R5的路径增加了另一个链接,因此增加了成本。)

福彩三d字谜协议路由示例

福彩三d字谜接口

福彩三d字谜中的另一个重要思想是用于与福彩三d字谜邻居交换信息的接口具有不同的类型。这里讨论的类型太多,但是您应该意识到两个重要的类型。

  1. 福彩三d字谜协议 广播 接口连接到共享网络,例如以太网。
  2. 福彩三d字谜协议 点对点 接口连接到链路,该链路的两端只能有一个福彩三d字谜路由器,例如WAN链路或专用的以太网链路。

各种接口类型的原因是要确保所有路由器都知道来自所有其他路由器的所有路由。

在点对点链接上,没有什么神秘之处-这两个路由器知道它们是链接上唯一的福彩三d字谜路由器,因此它们彼此交换路由。

在广播链路上,网段上可能会有许多不同的福彩三d字谜路由器。为了最大程度地减少在广播链路上形成的邻居关系,福彩三d字谜选择了一个 指定路由器 (以及备份),其任务是与网段上的所有其他福彩三d字谜路由器相邻,并与其他所有人共享所有人的路由。

福彩三d字谜区域

福彩三d字谜中的区域是分组在一起的路由器的集合。除了 区域边界路由器,一个区域中的福彩三d字谜路由器与其他区域中的路由器不相邻。除其他原因外,区域曾经用于扩展大型福彩三d字谜网络。

当路由器CPU的功能不如今天那么强大时,通常的经验法则是使福彩三d字谜区域最多容纳50个路由器。随着接口的上升和下降,路由的学习和撤销等等,这将使福彩三d字谜最短路径计算和数据库更新的数量保持在可管理的数量。

在现代网络中,在一个区域内扩展到一千个或更多路由器的情况并非没有听说过-路由器CPU已经走了很长一段路。

如今,尽管规模并不是实现多个区域的主要原因,但是福彩三d字谜区域仍然可以用作网络中的管理边界。例如:

  • 路线汇总&聚合(将几个小路由替换为一个覆盖它们的较大路由)只能在福彩三d字谜区域边界进行。
  • 并非所有路由器都需要知道网络中所有其他可用的路由。使用福彩三d字谜区域,可以注入一个默认路由,该路由代表本地区域之外的所有路由。

如果您认为自己应该能够汇总或过滤区域内福彩三d字谜路由器之间的路由,则问题在于,要使最短路径优先(SPF)计算起作用,区域中的所有路由器都必须具有相同的“图片”网络。因此,不可能隐藏区域中福彩三d字谜路由器之间的路由。

(您可能熟悉的一种福彩三d字谜过滤类型实际上是福彩三d字谜路由信息库(RIB)和路由器的转发信息库(FIB)之间的过滤器。本地福彩三d字谜进程仍将有关已过滤路由的信息传递给其他福彩三d字谜邻居。 )

福彩三d字谜最重要的领域是 骨干 区域,也称为区域0。主干区域是所有福彩三d字谜区域必须穿越才能到达其他福彩三d字谜区域的区域。

例如,假设我们有区域0,区域1和区域2。区域1的流量必须经过区域0才能到达区域2,反之亦然。即使有一个路由器在区域1中有一个接口,而在区域2中有另一个接口,区域1和2的流量也无法直接通过该路由器。这样做的原因是防止循环。

尽管区域内的福彩三d字谜路由器了解网络拓扑的所有知识,但拓扑信息隐藏在区域边界。有关为何存在主干区域和相关遍历规则的更多详细信息,网络架构师 杰夫·道尔(Jeff Doyle)的一篇文章对此做了很好的解释.

福彩三d字谜协议骨干区域0

一个简单的两路由器福彩三d字谜网络

这是一个网络配置示例,该示例在两个Cisco路由器之间创建了一个非常简单的福彩三d字谜网络。将路由器放置在区域0中,并在它们之间配置福彩三d字谜点对点链接。 R1将宣布1.1.1.1/32路由,R2将宣布2.2.2.2/32。让我们来看一看。

福彩三d字谜协议网络路由示例

R1的配置

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet2
 description 福彩三d字谜 Transit
 ip address 10.200.1.1 255.255.255.252
! Set this interface type to be “point to point”. Put another way, there will be no “designated router” on this segment.
 ip ospf network 点对点
!
! Start an 福彩三d字谜 process with an ID of 200. This process number isn’t super important -- both sides do *not* have to match. 的 process ID distinguishes it from other 福彩三d字谜 processes you might be running on your router.
router ospf 200
! If you don’t set an 福彩三d字谜 router ID, the router will choose the highest IP of a loopback interface. If there are no loopback interfaces, the highest IP assigned to any router interface will be chosen. If you change the router ID, you’ll have to clear the 福彩三d字谜 process for it to become active, briefly knocking down 福彩三d字谜 adjacencies with 邻居.
 router-id 10.200.2.1
! As 福彩三d字谜 邻居 communicate, details are logged. Can be helpful in troubleshooting 福彩三d字谜 adjacency issues.
 log-adjacency-changes detail
! Place any interface with an IP address matching 1.1.1.1/32 into 福彩三d字谜 区 0. This line will match interface Loopback0 on this router.
 network 1.1.1.1 0.0.0.0 区 0
! Place any interface with an IP address matching 10.200.1.0/30 into 福彩三d字谜 区 0. This line will match interface GigabitEthernet2 on this router.
 network 10.200.1.0 0.0.0.3 区 0

R2的配置

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet2
 description 福彩三d字谜 Transit
 ip address 10.200.1.2 255.255.255.252
 ip ospf network 点对点
!
router ospf 200
 router-id 10.200.1.2
 log-adjacency-changes detail
 network 2.2.2.2 0.0.0.0 区 0
 network 10.200.1.0 0.0.0.3 区 0

福彩三d字谜基本命令

现在已经配置了福彩三d字谜,让我们看一下Cisco IOS和类似的行业标准CLI上可用的一些基本福彩三d字谜命令。为了方便阅读和说明,我将一些命令输出截短了。

命令“ show ip ospf neighbor”显示福彩三d字谜邻居及其状态。在这种情况下,我们看到R1和R2通过其GigabitEthernet 2接口完全彼此相邻。

邻居ID 等于邻居的路由器ID。

优先 与指定路由器的选择有关-对于我们的简单示例而言并不重要。

在点对点链路上,福彩三d字谜 应该是“满”。如果不是,则可能是发生了问题。

死的时间 是一个倒数计时器,当从邻居那里听到消息时,它会不断重置。如果停滞时间为零,则假定邻居已死,邻接关系被拆除,并且从福彩三d字谜数据库中的SPF计算中删除了该链接。

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.200.1.2        0   FULL/  -        00:00:33    10.200.1.2      GigabitEthernet2
R1#

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.200.2.1        0   FULL/  -        00:00:30    10.200.1.1      GigabitEthernet2
R2#

查看设备的转发表时,“ show ip route ospf”仅显示通过福彩三d字谜进入转发表的路由。

在我们的情况下,R1将通过福彩三d字谜知道2.2.2.2/32路由,而R2将通过福彩三d字谜知道1.1.1.1/32。为什么在R1或R2上没有将10.200.1.0/30路由显示为福彩三d字谜路由?因为10.200.1.0/30也是 连接路线。连接的路由胜过福彩三d字谜获悉的路由。

R1#show ip route ospf
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 10.200.1.2, 00:43:45, GigabitEthernet2
R1#

R2#show ip route ospf
      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 10.200.1.1, 00:44:13, GigabitEthernet2
R2#

有用的福彩三d字谜指南

关于福彩三d字谜的信息比我们在博客文章中可以找到的更多。实际上,整本书都写过关于这个主题的书。我希望您的好奇心被激发去探索和了解更多。

在我运行福彩三d字谜网络的多年中,我已经多次提及某些参考。希望他们能对您有所帮助。